OA Public Site Unavailable

Incident Report for Order of the Arrow

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 10:33 EST

Investigating

We are aware that OA-Scouting.org is currently unavailable. Our team is investigating the issue and working toward a resolution. We appreciate your understanding and will post additional updates as soon as we have more information.
Posted Feb 13, 2026 - 09:55 EST
This incident affected: Order of the Arrow (OA Public Site).